Installation

Upgrading to 8.0 questions

vrmandadi
Builder

Currently we are running Splunk 7.1.8 and want to upgrade to 8.0 and have the following questions

1) Do we need to upgrade python on all splunk instances to 3.0 .If needed to be upgraded what is the location of it?
2)Do we need to install java as well?

Thanks in Advance

Labels (1)
0 Karma
1 Solution

gcusello
SplunkTrust
SplunkTrust

Hi @vrmandadi,
as you can see at https://docs.splunk.com/Documentation/Splunk/8.0.2/Installation/AboutupgradingREADTHISFIRST Splunk 8 contains Python 3 but it's also compatible with Python 2.7.
So you have to upgrade to 8 and put in $SPLUNK_HOME/etc/system/local/server.conf, in the [general] stanza the option python.version = python3 .

Before do this, I suggest to install the Splunk Platform Upgrade Readiness App ( https://splunkbase.splunk.com/app/4698/ ) that gives you information about the apps you are using and their compatibility with Splunk 8.

You don't need to install java.

It's better to upgrade Splunk in all instances following the procedure described at https://docs.splunk.com/Documentation/Splunk/8.0.2/Installation/AboutupgradingREADTHISFIRST

In few words, follow this order: before Master Node, then Search Heads, Indexers, Heavy Forwarders and (if you need) also Universal Forwarders.

Ciao.
Giuseppe

View solution in original post

gcusello
SplunkTrust
SplunkTrust

Hi @vrmandadi,
as you can see at https://docs.splunk.com/Documentation/Splunk/8.0.2/Installation/AboutupgradingREADTHISFIRST Splunk 8 contains Python 3 but it's also compatible with Python 2.7.
So you have to upgrade to 8 and put in $SPLUNK_HOME/etc/system/local/server.conf, in the [general] stanza the option python.version = python3 .

Before do this, I suggest to install the Splunk Platform Upgrade Readiness App ( https://splunkbase.splunk.com/app/4698/ ) that gives you information about the apps you are using and their compatibility with Splunk 8.

You don't need to install java.

It's better to upgrade Splunk in all instances following the procedure described at https://docs.splunk.com/Documentation/Splunk/8.0.2/Installation/AboutupgradingREADTHISFIRST

In few words, follow this order: before Master Node, then Search Heads, Indexers, Heavy Forwarders and (if you need) also Universal Forwarders.

Ciao.
Giuseppe

View solution in original post

vrmandadi
Builder

Thank you Giuseppe .So we need not install Python when upgrading to 8.0 if I am understanding you correctly and but the general stanza needs to be upgraded as mentioned.

0 Karma

gcusello
SplunkTrust
SplunkTrust

Yes, otherwise Splunk continue by default to use python 2.7.
you can check the python version with the command splunk cmd python -V

python.version is set to python2 by default in Splunk Enterprise version 8.0. To specify Python 3, set python.version = python3. These settings specify the interpreter to use if a script-level setting has not been specified, but script-level settings take precedence over the global setting, except if Python 3 is forced.

To force Splunk Enterprise to use only the Python 3 interpreter regardless of script-level setting, set python.version = force_python3. Use this setting if you cannot run Python 2.7 past its EOL date of January 1, 2020, or if your Splunk Enterprise deployment and all Splunk apps and add-ons are fully migrated and ready to run Python 3 only.

Splunk Enterprise version 8.0 also includes python.version settings to control which version of the Python interpreter is used by Splunk Enterprise at the script-level. For the following scripts, the python.version setting resides in the corresponding conf file

Ciao.
Giuseppe

0 Karma
.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!