Installation

Scripted upgrade failing for Linux Universal forwarder

kathyl
Engager

I am trying to upgrade 30 Universal Forwarders from 7.1.2 to 9.0.2 on Linux.  I've read several responses here including this one: https://community.splunk.com/t5/Installation/Scripted-install-thrown-by-upgrade-prompt/m-p/46594 but it is not working for me.  Here is what I have tried:

/opt/splunkforwarder/bin/splunk start --accept-license --answer-y
/opt/splunkforwarder/bin/splunk start --accept-license --answer-y --no-prompt

Installing manually (from the command line and answering the prompt) works, but I really want to script this.  But first I have to figure out how to avoid getting the upgrade prompt.  Are there any other ideas to help me do this?

Labels (3)
0 Karma

kathyl
Engager

And I just tried a little somethig and it worked.  The answer was using:

--answer-yes  vice --answer-y.

Hope this helps someone else

 

richgalloway
SplunkTrust
SplunkTrust

Perhaps it was a typo when posting the question, but the correct option name to suppress prompts is --answer-yes.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...