Installation

Python 3.7 to 3.9

BrianS
Observer

Question to all:

I need to address a vulnerability we found, CVE-2021-3177.  In order to do this, I need to upgrade Python to at least 3.9.1-3.

 

My two questions on this:

1. Will this break Splunk?

2. How can I accomplish this?

 

Thanks

Labels (1)
Tags (2)
0 Karma

kbambrick_splun
Splunk Employee
Splunk Employee

Splunk updated Python3 to 3.7.10 in Splunk Enterprise 8.1.3, which remediates CVE-2021-3177.

richgalloway
SplunkTrust
SplunkTrust

1. Possibly

2. Tell Splunk about the vulnerability at https://ideas.splunk.com . Also, submit a support request.  Then wait for Splunk to release a version of Python that fixes the vulnerability.

---
If this reply helps you, an upvote would be appreciated.
0 Karma