Installation

Monitor new Splunk admin creation

anel
Explorer

Is there a way to monitor the creation of new Splunk users/admins? 

I want to be notified if someone creates a new Splunk admin. 

Labels (2)
0 Karma
1 Solution

SanjayReddy
SplunkTrust
SplunkTrust

Hi @anel 

you can use following query


index="_audit" source=audittrail action=create_user
| stats count by timestamp user info username fullname email roles default_app
| rename user as "New Users Created by" username as "New User Created for"


from this you will get to know who addeed new users and deatils using this you can create alert



----
Regards,
Sanjay Reddy

---
If this reply helps you, Karma would be appreciated.

If your problem is resolved, then please click the "Accept as Solution" button to help future readers.

View solution in original post

SanjayReddy
SplunkTrust
SplunkTrust

Hi @anel 

you can use following query


index="_audit" source=audittrail action=create_user
| stats count by timestamp user info username fullname email roles default_app
| rename user as "New Users Created by" username as "New User Created for"


from this you will get to know who addeed new users and deatils using this you can create alert



----
Regards,
Sanjay Reddy

---
If this reply helps you, Karma would be appreciated.

If your problem is resolved, then please click the "Accept as Solution" button to help future readers.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...