Installation

App Compatibility with Python 3

gcusello
Legend

Hi at all,

I installed the following apps on Splunk 8.2.2:

  • Lookup Editor App 3.5.0,
  • Machine Learning ToolKit 5.3.0.

but, from the Python Upgrade Readiness App, I'm receiving the following warning message: "The app is not compatible with Python3" for both these apps.

Had anyone found the same problem?

how to solve it?

Thank you and Ciao.

Giuseppe

Labels (1)
0 Karma
1 Solution

gjanders
SplunkTrust
SplunkTrust

The app is not accurate when it comes to checking python3 compatibility.

If you are referring to https://splunkbase.splunk.com/app/1724/ , Lookup File Editor then it is using python3 on my 8.2.2.1 instance without an issue.

I suspect it's the same with the other app, the application checker is not completely accurate...

Alerts for Splunk Admins https://splunkbase.splunk.com/app/3796/
Version Control for Splunk https://splunkbase.splunk.com/app/4355/

View solution in original post

gjanders
SplunkTrust
SplunkTrust

The app is not accurate when it comes to checking python3 compatibility.

If you are referring to https://splunkbase.splunk.com/app/1724/ , Lookup File Editor then it is using python3 on my 8.2.2.1 instance without an issue.

I suspect it's the same with the other app, the application checker is not completely accurate...

Alerts for Splunk Admins https://splunkbase.splunk.com/app/3796/
Version Control for Splunk https://splunkbase.splunk.com/app/4355/

View solution in original post

Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!