Getting Data In

len(_raw) vs |dbinspect rawSize

Hoekb03
Explorer

I use a simple query to determine the amount of data I've sent to splunk:

index=x
|eval esize=len(_raw)
|timechart sum(esize) span=1h

This is pretty expensive when ran over long timeranges. I also tried this:

|dbinspect index=x
|eval date=strftime(startEpoch,"%F")
|chart sum(rawSize) over date
|rename sum(*) -> *

The results are different, dbinspect reporting lower values than len(_raw).

Any ideas on a cheap way to get the right results?

0 Karma

FrankVl
Ultra Champion

I usually get that sort of info from the license usage events in _internal.

Eg:

index="_internal" source="*license_usage.log" type=Usage 
| bin _time span=1d 
| stats sum(b) AS bytes by _time,idx 
| eval DailyGB=bytes/1024/1024/1024 
| timechart sum(DailyGB) by idx span=1d
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...