Getting Data In

how to remove comma in number

jip31
Builder

hi

I try to remove the comma in my number but it doesnt works

Could you help me please?

| rex field=count mode=sed "s/,/./g" 
| stats count(HOSTNAME)

 

Labels (1)
Tags (1)
0 Karma
1 Solution

ITWhisperer
Ultra Champion

For single visualisations try:

<option name="useThousandSeparators">false</option>

View solution in original post

0 Karma

saravanan90
Contributor

This may help..

| rex field=count mode=sed "s/,//g"

0 Karma

jip31
Builder

like this?

 

| stats count(HOSTNAME) 
| rex field=count mode=sed "s/,//g"

it doesnt works

0 Karma

saravanan90
Contributor

we can use like below..

| stats count(HOSTNAME) | rex field=count(HOSTNAME) mode=sed "s/,//g"

0 Karma

richgalloway
SplunkTrust
SplunkTrust

The rex command is trying to modify a field that will be created/modified by the stats command which follows.  Since the count function does not include commas there is no need to remove them.

If this does not solve the problem then please add more information to describe the problem.  Include sample results.

---
If this reply helps you, an upvote would be appreciated.
0 Karma

jip31
Builder

My number which is one thousand three hundred thirty is displayed like this : "1,330" and I want this : "1330"

0 Karma

ITWhisperer
Ultra Champion

In your simple xml, format the fields like this

 

        <format type="number" field="count(HOSTNAME)">
          <option name="precision">0</option>
          <option name="useThousandSeparators">false</option>
        </format>

 

0 Karma

jip31
Builder

I have the message  "Node <format> is not allowed here"

I put the xml like this :

 

 </search>
        <option name="colorBy">value</option>
        <option name="colorMode">block</option>
        <option name="drilldown">none</option>
        <option name="numberPrecision">0</option>
        <option name="rangeColors">["0x53a051","0x53a051"]</option>
        <option name="rangeValues">[0]</option>
        <option name="refresh.display">progressbar</option>
        <option name="useColors">1</option>
        <format type="number" field="count">
          <option name="precision">0</option>
          <option name="useThousandSeparators">false</option>
        </format>
      </single>
0 Karma

ITWhisperer
Ultra Champion

For single visualisations try:

<option name="useThousandSeparators">false</option>

View solution in original post

0 Karma

jip31
Builder

thanks it works now!!

0 Karma
.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!