Getting Data In

data ingest size from a server

jiaqya
Builder

how to identify data ingest size from a server per day...

looking to find sizes of data ingested from each server for planning ..

Tags (1)
0 Karma
1 Solution

adonio
Ultra Champion

this is one way:

earliest=-1d@d latest=@d  index=_internal source=*license_usage.log* type=Usage
| stats sum(b) AS Bytes by h
| eval GB = Bytes/1024/1024/1024
| table h GB
| sort -GB

explore the data h stands for host
there are many many ways to get this data and quick search in this portal will prompt you to dozens of results
hope it helps

View solution in original post

0 Karma

adonio
Ultra Champion

this is one way:

earliest=-1d@d latest=@d  index=_internal source=*license_usage.log* type=Usage
| stats sum(b) AS Bytes by h
| eval GB = Bytes/1024/1024/1024
| table h GB
| sort -GB

explore the data h stands for host
there are many many ways to get this data and quick search in this portal will prompt you to dozens of results
hope it helps

0 Karma

jiaqya
Builder

Adonio, thanks for your reply, unfortunately the query you gave returned 0 records.
i tried running this on the forwarder where i am inserting data via file inputs.

also i could not find any other document which can give me a ingest rate ..

0 Karma

jiaqya
Builder

thanks, running it on search head gave me the result.

0 Karma

adonio
Ultra Champion

are you an admin? or do you have admin role?
you are supposed to run queries on the Search Head

0 Karma

SamHTexas
Builder

Sir, how would I calculate he total amount of ingestion into an average server if only logs & small / Med DBs are ingested into the Splunk server? Thanks a million in advance.

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...