Getting Data In

access problem for delte command ??

rakesh_498115
Motivator

Hi ..

For the Splunk default admin login also , i am getting this error
"#Error in 'delete' command: You have insufficient privileges to delete events" ,
when i use the delete command .. What settings i have to change to get rid of this error ??.

please help thanx.

Tags (2)
1 Solution

echalex
Builder

Hi,

The delete command requires special privileges, which aren't granted to anyone by default, not even admin. Check the documentation for the delete command. The reason is that the delete command is destructive and irrevokable.

You can grant a user the can_delete role to enable deleting. It is highly recommended that you do this only temporarily for a specific user and remove the role immediately when you're finished deleting.

View solution in original post

echalex
Builder

Hi,

The delete command requires special privileges, which aren't granted to anyone by default, not even admin. Check the documentation for the delete command. The reason is that the delete command is destructive and irrevokable.

You can grant a user the can_delete role to enable deleting. It is highly recommended that you do this only temporarily for a specific user and remove the role immediately when you're finished deleting.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...