Getting Data In

WinEventLog Milli seconds identification.

thirumalreddyb
Communicator

Splunk is not parsing the milliseconds into _time field. How to parse it during the index time?

I have updated my TIME_FORMAT in props in all the search peers; yet it is not parsing properly.

Thanks in advance.

0 Karma

hettervik
Builder

After looking some more into the problem with Splunk not extracting milliseconds from WinEventLog, I found this thread:

https://answers.splunk.com/answers/489938/splunk-add-on-for-microsoft-windows-why-is-timesta.html

It seems to be the answer for your question. Unfortunately the timestamp for WinEventLog is parsed at input time, and cannot be corrected later on at indexs time.

0 Karma

hettervik
Builder

Hi. Did you find out why your parsing for WinEventLog doen't extract the milliseconds? I seem to have the same problem. I've sat TIME_FORMAT in props.conf, but still it seems to be ignored. Also I've checked using the data onboarding UI in Splunk that the TIME_FORMAT setting is indeed correct for the logs.

0 Karma

teunlaan
Contributor

Does you WinEventLog have milliseconds in the timestamp?

0 Karma

thirumalreddyb
Communicator

I downvoted this post because this is not an answer. this prevented others from looking into the question.

0 Karma

thirumalreddyb
Communicator

Yes, this is that format => %Y-%m-%dT%H:%M:%S.%9NZ

0 Karma

teunlaan
Contributor

so if you do index=windows| table _raw You also see the milliseconds in the message?

how do you collect the Wineventlog? "normal" or by xml?

0 Karma

thirumalreddyb
Communicator

We collect them in xml format.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Design, Compete, Win: Submit Your Best Splunk Dashboards for a .conf26 Pass

Hello Splunkers,  We’re excited to kick off a Splunk Dashboard contest! We know that dashboards are a primary ...

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...