Getting Data In

Why is My Splunk 7.0.2 Install Missing HTTP Event Collector Option?

trumpjk
Explorer

I would like to setup HEC but do not see the option under Settings -> Data Inputs. What do I have to do to enable HEC? The server I am trying to configure this on is the indexer, not clustered but set up to do a distributed search.

0 Karma

iandrews_splunk
Splunk Employee
Splunk Employee

I see it in mine. Do you have the "splunk_httpinput" app in etc/apps?

0 Karma

trumpjk
Explorer

Yes it is there. Here is what is in the inputs.conf:

[http]
disabled=1
port=8088
enableSSL=1
dedicatedIoThreads=2
maxThreads = 0
maxSockets = 0
useDeploymentServer=0

ssl settings are similar to mgmt server

sslVersions=*,-ssl2
allowSslCompression=true
allowSslRenegotiation=true

NOTE: Disabled was set to 0, I changed to 1 but made no difference.

0 Karma
Get Updates on the Splunk Community!

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...

Splunkbase | Splunk Dashboard Examples App for SimpleXML End of Life

The Splunk Dashboard Examples App for SimpleXML will reach end of support on Dec 19, 2024, after which no new ...

Understanding Generative AI Techniques and Their Application in Cybersecurity

Watch On-Demand Artificial intelligence is the talk of the town nowadays, with industries of all kinds ...