Getting Data In

Why is HTTP Event Collector listening only on 127.0.0.1 (localhost) address?

rvencu
Path Finder

I enabled the HTTP Event Collector and I can see on my Centos 7 by running the ss -an command that it is listening only on 127.0.0.1 address. As a result the curl is working when calling 127.0.0.1:8088 and connection is refused when calling :8088 from the local ssh terminal

Any idea how to fix this issue?

0 Karma
1 Solution

rvencu
Path Finder

I solved it. My free splunk is deliberately set to be accessible only from localhost because user authentication can be done only through an NGINX reverse proxy. Hence the listening limitation.

I added a second reverse proxy setting for the HTTP Event Collector and all is working fine now.

View solution in original post

rvencu
Path Finder

I solved it. My free splunk is deliberately set to be accessible only from localhost because user authentication can be done only through an NGINX reverse proxy. Hence the listening limitation.

I added a second reverse proxy setting for the HTTP Event Collector and all is working fine now.

View solution in original post

Filmhooligan
New Member

I think I'm having a similar issue, we have an Apache2 reverse proxy in front of our Splunk instance, what type of setting did you configure to allow the HEC explicitly?

0 Karma

rvencu
Path Finder

[root@splunk ~]# firewall-cmd --list-all
public (default, active)
interfaces: eth0
sources:
services: dhcpv6-client ssh
ports: 443/tcp 80/tcp 2222/tcp 4443/tcp 8886/tcp 8088/tcp
masquerade: no
forward-ports:
icmp-blocks:
rich rules:

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!