Getting Data In

Why am I receiving the following error "WARNING: web interface does not seem to be available!" when pushing HTTP Event Collector(HEC) configurations to Heavy Forwarders (HF)?

sylim_splunk
Splunk Employee
Splunk Employee

After HEC configurations are pushed to our HF, Splunk service fails to start.

This is happening to all the HF that received the new HEC configurations.

0 Karma
1 Solution

sylim_splunk
Splunk Employee
Splunk Employee

There is a known issue in this regards - if there are any duplicate tokens for HEC in search/local/inputs.conf the splunkd/splunkweb will fail to start and puts log message on the screen.

WARNING: web interface does not seem to be available!

  • Run to find the duplicate token in inputs.conf

$ splunk btool --debug inputs list | grep "token =" | cut -d "=" -f 2 |sort |uniq -c | awk '{ if ($1 > 1) print $2}'

  • The fix has been included in 7.0.6+ and 7.1.3+.

View solution in original post

sylim_splunk
Splunk Employee
Splunk Employee

There is a known issue in this regards - if there are any duplicate tokens for HEC in search/local/inputs.conf the splunkd/splunkweb will fail to start and puts log message on the screen.

WARNING: web interface does not seem to be available!

  • Run to find the duplicate token in inputs.conf

$ splunk btool --debug inputs list | grep "token =" | cut -d "=" -f 2 |sort |uniq -c | awk '{ if ($1 > 1) print $2}'

  • The fix has been included in 7.0.6+ and 7.1.3+.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...