Getting Data In

Why am I receiving "SOFTWARE PROGRAM ERROR" in Splunk universal forwarder that are AIX servers?

MousumiChowdhur
Contributor

I'm running error script on a bunch of AIX servers but have encountered the "SOFTWARE PROGRAM ERROR" on few of the servers. After getting the internal logs of the servers I have found that whenever there is an automatic restart of that server, this "SOFTWARE PROGRAM ERROR" generates. What should I do to prevent this error from coming up in the servers? Also, what could be the other possible root causes for this getting this error?

gcusello
SplunkTrust
SplunkTrust

Hi MousumiChowdhury,
what version of Splunk Forwarder are you using?
because there is a known issue on AIX7.1.
I suggest to open a case to Splunk Support.
Bye.
Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...