Getting Data In

Uploading flat/sequential file

petem3
New Member

I'm trying to upload an ascii file (created on a IBM mainframe) into splunk using the lookup - add new lookup table file option.

Its not a CSV format, just text with no comma separated fields (also known as a flat/sequential file).

I'm getting the following error :-

"Encountered the following error while trying to save: File is binary or file encoding is not supported, only utf-8 encoded files are supported".

Am i using the correct option to get the data into splunk, if yes, how do i overcome the error?

 

  

  

Labels (1)
0 Karma

petem3
New Member

Thanks for the speedy response.

Ultimately i would like to index the file, but currently just trying to ingest into splunk and have a play around with it.

0 Karma

richgalloway
SplunkTrust
SplunkTrust

For simple data ingestion, use the Add Data wizard at Settings->Add Data.

---
If this reply helps you, an upvote would be appreciated.
0 Karma

richgalloway
SplunkTrust
SplunkTrust

Make sure the file uses the UTF-8 character set.  Remove any non-printable characters.  IBM has a history of not supporting ASCII well so the file may not be what you think it is.

A file without commas will not work as a Splunk lookup file.

To know if you're using the correct option requires knowing what you're trying to accomplish.  What do you want to do with this file?  Do you want to index it, make it into a lookup file, or something else?

---
If this reply helps you, an upvote would be appreciated.
0 Karma
.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!