Getting Data In

Unable to start splunk forwarder service

catch_mili
Explorer

Unable to start splunk forwarder service, below error returns.

checking mgmt port [8089]: already bound
ERROR: The mgmt port [8089] is already bound. Splunk needs to use this port.
Would you like to change ports? [y/n]:

Tags (2)
0 Karma

HansK
Path Finder

seems there is allready another service listening on 8089, eiter change the splunk port or the other software's port.

try this:
netstat --tcp --udp --listening --program

catch_mili
Explorer

Thanks. Vince.

0 Karma

vincesesto
Communicator

Hey catch_milli, try checking the running processes like:
ps aux | grep 8089
Regards Vince

0 Karma

HansK
Path Finder

and like this?:
lsof -i TCP:8089

0 Karma

catch_mili
Explorer

I dont see 8089 used by any other application
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 :nrpe *: LISTEN 1321/xinetd
tcp 0 0 :nsca *: LISTEN 1321/xinetd
tcp 0 0 :http *: LISTEN 8343/httpd
tcp 0 0 localhost:oa-system

0 Karma

martin_mueller
SplunkTrust
SplunkTrust

As the error says, someone else (a splunk instance?) is hogging port 8089. Either kill them or switch to a different one.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...