Getting Data In

Troubleshooting: SplunkHecExporter in otelcol-contrib : How to change the source filed to take the file name

Bxannas
Observer

Configured the otelcol-contrib  agent.config.yaml file to send the data to splunk cloud. i'm getting the data but the source is coming as HEC Token name. 

receivers is configured to read different files. 

filelog/sys:
include: [ /var/log/messages, /var/log/auth, /var/log/mesg$$, /var/log/cron$$, /var/log/acpid$$ ]
start_at: beginning
include_file_path: true
include_file_name: false
 
Exporters: 
in the exporters didn't mention the source.
option 1 : By default Splunk is taking the HEC token name as it's value.
option 2 : I can give the value as log file path but for multiple files, it's not working . 
 
in splunk cloud, source is - HEC Token value 
                     log_file_path field is giving the log file path.  Is there a way i can configure the source to take the log file path.
 
Labels (1)
0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...