Getting Data In

TA-nmon,, nmon.fifo not running, permission denied


The TA-nmon is not sending data to 'nmon' index on my splunk instance. I was looking through the troubleshoot guide for TA-nmon and I noticed that the forwarder was not running any of the three expected running processes (,, nmon.fifo) when I ran a 'ps -ef | egrep nmon'. I tried starting these processes manually but it returned the message:



couldn't run "/opt/osi/splunkforwarder/etc/apps/TA-nmon/bin/": Permission denied



I saw another solution to this issue where the user changed the permissions for these exectuables, how would I do that? 

Labels (2)
0 Karma

Re: TA-nmon,, nmon.fifo not running, permission denied


Disregard the question, I gave permissions to these processes and they are running correctly now. Additionally, data is being sent to the 'nmon' index in Splunk which is good, but it is only sending the following data:


Why are none of the metrics being forwarded?

When I try to start nmon using:

/opt/splunkforwarder/bin/splunk cmd /opt/splunkforwarder/etc/apps/TA-nmon/bin/

 It gives the error:

ERROR nmon:diskgroup file - failed to find disk=fd0 for group=fd0 disks known=16

and stalls there until I manually cancel it. I assume this is the issue, how would i fix this.

0 Karma
Speak Up for Splunk Careers!

We want to better understand the impact Splunk experience and expertise has has on individuals' careers, and help highlight the growing demand for Splunk skills.