Getting Data In

Successful dormant user logins

saurabh_tek
Communicator

hello I am trying to write a query for Successful dormant user logins
whereas the user has successfully logged in today but in last 30 days there was no activity done by this same user.

Here is my query - (which needs refinement)

index=wineventlog EventCode=4624 user!="$" earliest= @d latest = now()| transaction user [search EventCode!=4624 user!="$" earliest=-2d latest=@d] | table _time, user

if anyone can help in getting this refined and do what is needed, that would be great help.

0 Karma

richgalloway
SplunkTrust
SplunkTrust

Perhaps this will help. The idea is to look at the last 30 days of successful logins and find the users that have signed in only once and that login was today.

index=wineventlog EventCode=4624 user!="$" earliest= -30d@d | stats count(_time) as Logins latest(_time) as LastLogin by user | where Logins=1 AND LastLogin>relative_time(now(),"@d") | ...
---
If this reply helps you, Karma would be appreciated.
0 Karma

saurabh_tek
Communicator

Thanks for prompt support.
With earliest 30 days, it takes way too much time and showing lot of users with 1 logins, i dont think these many users accessing their dormant a/cs in our environment.

0 Karma

saurabh_tek
Communicator

okay. I have optimized it a little bit apparently ..

index=wineventlog EventCode=4624 user!=\"$\" earliest= @d latest = now() | transaction user maxspan=60d search (EventCode!=)

looking for more suggestions.. to get this working what is intended

0 Karma

saurabh_tek
Communicator

okay. I have optimized it a little bit apparently ..

index=wineventlog EventCode=4624 user!="$" earliest= @d latest = now() | transaction user maxspan=60d search (EventCode!=)

looking for more suggestions.. to get this working what is intended

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Defend at Machine Speed: Your Guide to Security Sessions at .conf26

Splunk .conf26   With threats moving at machine speed and attack surfaces expanding across hybrid ...

Where Innovation Takes Flight: The Splunk4Aviation Flight Sim Lands at .conf26

If you hear someone at .conf26 shouting "gear down, GEAR DOWN" across the show floor, you have found us.  The ...

Turn Cisco Telemetry Into Action with Cisco Data Fabric, powered by the Splunk ...

The surge in machine data is already hitting enterprise budgets, and the agentic era will only intensify it. ...