Getting Data In

Report all Logon Activity != United States

itsmevic
Communicator

I'd like to pull a logon report that shows me any logon activity that is  != to the United States.  Any help is greatly appreciated.

0 Karma
1 Solution

General_Talos
Path Finder

Try this

| tstats `summariesonly` values(Authentication.action) as action,values(Authentication.app) as app,count from datamodel=Authentication.Authentication where *   (Authentication.src="*") (Authentication.dest="*") by Authentication.src_ip,Authentication.src_user,Authentication.user  
|  `drop_dm_object_name("Authentication")`
| iplocation src_ip
| where Country!="United States"

You can change your search based on requirement and identify the field name (like src_ip / dest_ip) for which you want to identify geo_location and use | iplocation <field_name>

https://docs.splunk.com/Documentation/Splunk/8.1.1/SearchReference/Iplocation

View solution in original post

General_Talos
Path Finder

Try this

| tstats `summariesonly` values(Authentication.action) as action,values(Authentication.app) as app,count from datamodel=Authentication.Authentication where *   (Authentication.src="*") (Authentication.dest="*") by Authentication.src_ip,Authentication.src_user,Authentication.user  
|  `drop_dm_object_name("Authentication")`
| iplocation src_ip
| where Country!="United States"

You can change your search based on requirement and identify the field name (like src_ip / dest_ip) for which you want to identify geo_location and use | iplocation <field_name>

https://docs.splunk.com/Documentation/Splunk/8.1.1/SearchReference/Iplocation

itsmevic
Communicator

Thank you!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...