Getting Data In

REST Calls for license usage

mphalak
New Member

Today I have this search to alert me on license usage going beyond certain threshold:
Search: index=_internal source=*license_usage.log pool="auto_generated_pool_enterprise"| eval GB=b/1024/1024/1024 | stats sum(GB) as current_license_usage_auto_generated_pool_GB by pool

Due to some reasons I am getting wrong results for the above ....How can I change this search to use rest endpoints ??

Tags (2)
0 Karma

yannK
Splunk Employee
Splunk Employee

on 4.3, please specify a type of records, otherwise you may count things twice.

type=Usage

type=RolloverSummary

see the difference here : http://wiki.splunk.com/Community:TroubleshootingIndexedDataVolume

0 Karma

mphalak
New Member

Thanks I was able to get teh resulst with this search:

| rest /services/licenser/pools | where title= "auto_generated_pool_enterprise" | table used_bytes, title | eval GB=used_bytes/1024/1024/1024

BUT now when I set the same as saved search and try to send alert when GB>1 I see the following error:

DEBUG: search context: user="admin", app="tto_search", bs-pathname="/opt/splunk/etc"
INFO: No matching fields exist
WARN: Unable to fetch REST endpoint '/services/licenser/pools' from ''

ANY IDEA ???

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...