Getting Data In

Powershell Get-ADComputer not pulling in fields


I've been attempting to pull data in with powershell and Get-ADComputer to pull in fields like OperatingSystem and similar fields with this, I tried something more complicated with a select-object after Properties *, but it didn't populate data so I ended up with this to troubleshoot:


Get-ADComputer -Filter * -Properties DNSHostName,OperatingSystem,OperatingSystemVersion,Enabled,IPv4Address


I also tried


Get-ADComputer -Filter * -Properties *


 This doesn't populate more than the default fields from Get-ADComputer. Any tips would be appreciated, I haven't found much on this subject so far.

Labels (1)
0 Karma
Get Updates on the Splunk Community!

Mission Control | Explore the latest release of Splunk Mission Control (2.3)

We’re happy to announce the release of Mission Control 2.3 which includes several new and exciting features ...

Cloud Platform | Migrating your Splunk Cloud deployment to Python 3.7

Python 2.7, the last release of Python 2, reached End of Life back on January 1, 2020. As part of our larger ...

Splunk Observability Cloud | Enhancing Your Onboarding Experience with the ...

We understand that your initial experience with getting data into Splunk Observability Cloud is crucial as it ...