Getting Data In

Powershell Get-ADComputer not pulling in fields


I've been attempting to pull data in with powershell and Get-ADComputer to pull in fields like OperatingSystem and similar fields with this, I tried something more complicated with a select-object after Properties *, but it didn't populate data so I ended up with this to troubleshoot:


Get-ADComputer -Filter * -Properties DNSHostName,OperatingSystem,OperatingSystemVersion,Enabled,IPv4Address


I also tried


Get-ADComputer -Filter * -Properties *


 This doesn't populate more than the default fields from Get-ADComputer. Any tips would be appreciated, I haven't found much on this subject so far.

Labels (1)
0 Karma
Get Updates on the Splunk Community!

Enterprise Security Content Update (ESCU) | New Releases

In the last month, the Splunk Threat Research Team (STRT) has had 2 releases of new security content via the ...

Announcing the 1st Round Champion’s Tribute Winners of the Great Resilience Quest

We are happy to announce the 20 lucky questers who are selected to be the first round of Champion's Tribute ...

We’ve Got Education Validation!

Are you feeling it? All the career-boosting benefits of up-skilling with Splunk? It’s not just a feeling, it's ...