Getting Data In

Monitor Splunk Updates

ivan_yanev
Explorer

Hello,

I need some help. One of our clients wants to see when the patch version of Splunk is updated. Is this possible ? 

Labels (1)
0 Karma
1 Solution

manjunathmeti
Champion

hi @ivan_yanev ,
Check migration logs in _internal index.

 

index="_internal" source="*migration.log*" earliest=1 | table _time, host, PLATFORM, PRODUCT, VERSION, BUILD

 

If this reply helps you, an upvote/like would be appreciated.

View solution in original post

manjunathmeti
Champion

hi @ivan_yanev ,
Check migration logs in _internal index.

 

index="_internal" source="*migration.log*" earliest=1 | table _time, host, PLATFORM, PRODUCT, VERSION, BUILD

 

If this reply helps you, an upvote/like would be appreciated.

ivan_yanev
Explorer

@manjunathmeti thank you for your quick reply.

Probably this is correct but the internal index does not keep data older than 30 days so I cannot validate it.

I guess we'll find out if this work on next update.

UPDATE : I have decided to test it. I've updated the Splunk version of my virtual machine and it worked. 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...