Getting Data In

Line breaking stops working from 12am - 1am everyday

king2jd
Path Finder

Hello,

We have a distributed environment with load balancing to 9 indexers. At 12am, our logs stop line breaking and start group multiple entries into one event and random log lines (no timestamps) for the next hour. Then it miraculously starts to work again. Never seen such a thing, thoughts?

alt text

0 Karma

woodcock
Esteemed Legend

The problem is that your timestamp is using <date><SingleSpace><SINGLE digit hour=0> for the midnight hour but it is using <DATE><SingleSpace><DOUBLE digit hour> the rest of the time. So you need to make sure that your TIME_FORMAT, MAX_TIMESTAMP_LOOKAHEAD, LINE_BREAKER, etc. can each accommodate this variability. One of these is poorly-written enough to fail on the zero-hour because that format is different than all of the others.

burwell
SplunkTrust
SplunkTrust

Could this be an error in regex on the line breaking?

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...