Getting Data In

Indexed Data

whitecat001
Explorer

I made my configuration for inputs.conf to ingest data into splunk but not getting data, during my investigation to check if there is any issue i realize the configured source is not showing any data and i cant see the source path in the index in splunk. Is there a reason why am not seeing the source after configuring the inputs.conf 

Labels (1)
0 Karma

deepakc
Builder

It could be a n umber of things as to why the data is not coming through or not showing.

1.Whatever your monitoring does it have read permissions?
2.Check for typos' (index name etc)

You can also check the internal logs for clues

index=_internal sourcetype=splunkd host=neo log_level=INFO component=WatchedFile 
| table host, _time, component, event_message, log_level
| sort - _time

 

What is the output of this command - it shows whats being monitored (Assuming its a linux host)

/opt/splunk/bin/splunk list inputstatus

 

Are you able to show us your inputs.conf and describe what you are trying to monitor?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...