Getting Data In

How to make a search for some analytics with SPL?

10061987
Engager

Hi,

I need some analytics result in Splunk but i couldn't achieve. Here what i need.

1) Which EventIDs is repeated in which hostnames? I need this count based. EventID, Hostname and Count

2) Which EventIDs is used in which alerts (correleation searches and saved searches)? EventID, Alert Name

3) Which EventIDs triggered which alerts? EventID, Alert Name and count

Labels (1)
0 Karma

10061987
Engager

I tried below search for 2nd question but didn't work.

P.S: In my environment we parsed EventID as EventCode

| rest /services/saved/searches
| search is_scheduled=1 OR alert_type=1
| table title, actions
| mvexpand actions
| rex field=actions ".*EventCode=(?<EventCode>\d+).*"
| stats count by EventCode, title

 

Please help me..

0 Karma

10061987
Engager

I found 1. item with this search.

index=wineventlog
| stats count by EventCode, host
| where count > 1
| sort -count
| table EventCode, host, count

 

I need 2 and 3rd items

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Agentic SOC Triage: Investigating Splunk ES Notables with MCP Server and a Local LLM

The Problem: Too Many Alerts, Too Little Context Security operations teams running Splunk Enterprise Security ...

All Work and No Play? Not at .conf26! Unwind at These Evening Events

Between hands-on technical sessions, keynote reveals, and diving into live architectures, .conf26 is packed ...

Join the Hackathon at .conf26 and build a No-Code AI agent

Join us for the AI Agent Buildathon, an in-person, three-hour hands-on Hackathon where you’ll use Splunk Agent ...