Getting Data In

How to disable Windows universal forwarder service auto start after first installation?

New Member

I am using Citrix provisioning system to install Windows UFW (Universal Forwarder) 6.5.2 and got an issue:
after installed the UFW to gold image, the Splunk forwarder service automatically started. when the image push the image to the clients (shared hosts), only the last one Splunk can connect to deployment server.

Got help said that the Splunk forwarder service need set to NOT auto start after installation in gold image, but I could not find a way to disabled the forwarder service auto start (it is default to auto start) after installation.

If anyone got same issue or is there any way to using provisioning system to install UFW to multiple win hosts ?

Thank you.

0 Karma
1 Solution

Legend

On Windows, Splunk is installed as a service with the "Automatic" setting for startup by default. If you use msiexec to install Splunk, there are several installation switches that you can use to override this default behavior:

LAUNCHSPLUNK=0
SERVICESTARTTYPE=manual

With these two settings, Splunk will not be started after installation. You might want to read more about Windows command line installation here.

View solution in original post

Legend

On Windows, Splunk is installed as a service with the "Automatic" setting for startup by default. If you use msiexec to install Splunk, there are several installation switches that you can use to override this default behavior:

LAUNCHSPLUNK=0
SERVICESTARTTYPE=manual

With these two settings, Splunk will not be started after installation. You might want to read more about Windows command line installation here.

View solution in original post

New Member

Thanks lguinn!

0 Karma

Path Finder

SERVICESTARTTYPE=manual doesn't seem to work with the x64 forwarder msi 6.6.4 or 7.0.1 on Windows 10.

From the msiexec log:
MSI (s) (88:F0) [09:41:47:549]: Command Line: RECEIVINGINDEXER=10.2.1.100:9997 WINEVENTLOGSEC_ENABLE=1 SERVICESTARTTYPE=manual LAUNCHSPLUNK=0 AGREETOLICENSE=Yes CURRENTDIRECTORY=C:\WINDOWS\system32 CLIENTUILEVEL=3 CLIENTPROCESSID=3900

but
InstallSplunkService: Info: Execute string: cmd.exe /c ""C:\Program Files\SplunkUniversalForwarder\bin\splunk.exe" cmd splunkd install --startup=auto >> "C:\Users\xxx\AppData\Local\Temp\splunk.log" 2>&1"

0 Karma