Getting Data In

How get _time vaules same format?

Sekhar
Explorer

My query index= nonjVs source = nonjavs | stats vaules(_time ) as start time values(_time) as endtime by empid 

Displayed below formate but I want to see my stat time  and end time "%m-%d-%y %H:%M:@%S"

Starttime 165575758474.67768 

End time 16777894894.67788

 

Labels (1)
Tags (1)
0 Karma
1 Solution

gcusello
SplunkTrust
SplunkTrust

Hi @Sekhar,

you have to use the eval command, with the strftime funtion, after the stats command:

index=nonjVs source=nonjavs 
| stats earliest(_time) AS starttime latest(_time) AS endtime BY empid 
| eval starttime=strftime(starttime,"%m-%d-%y %H:%M:%S"), endtime=strftime(endtime,"%m-%d-%y %H:%M:%S")

 Ciao.

Giuseppe

View solution in original post

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @Sekhar,

you have to use the eval command, with the strftime funtion, after the stats command:

index=nonjVs source=nonjavs 
| stats earliest(_time) AS starttime latest(_time) AS endtime BY empid 
| eval starttime=strftime(starttime,"%m-%d-%y %H:%M:%S"), endtime=strftime(endtime,"%m-%d-%y %H:%M:%S")

 Ciao.

Giuseppe

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @Sekhar ,

good for you, see next time!

Ciao and happy splunking

Giuseppe

P.S.: Karma Points are appreciated 😉

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...