Getting Data In

How do I enable the HTTP Event Collector?

Ultra Champion

The following HTTP Event Collector walkthrough

says -

-- To enable it, in Splunk Enterprise and self-service or trial Splunk Cloud, go to Settings > Data inputs > HTTP Event Collector.

However, what I see in Settings > Data inputs of our dev environment is -

alt text

What can it be?

0 Karma

Legend

Run the Add Data wizard and select HTTP Event Collector. If it has not been initialized, it should automatically take you to the overview page where you can enter the global settings.
After that, you can use the Add Data wizard to add tokens.

I had this problem once, and after I entered the global settings, the HTTP Event Collector showed up on the Settings >> Data Inputs page.

If that doesn't work, it might be something quirky. If a Splunk restart doesn't fix it, I would enter a support ticket.

Ultra Champion

Thank you @lguinn - no luck with the bounce, so, I'll open a support ticket.

Much appreciated.

0 Karma

SplunkTrust
SplunkTrust

What version of Splunk are you using? (HEC available in 6.3+ versions).

0 Karma

Ultra Champion

We are on 6.5.2.

0 Karma

Ultra Champion

Interestingly, the feature does show up in Add Data -

alt text

0 Karma