Getting Data In

How do I Configure a Workflow to POST JSON Encoded Data?

klopez30
Explorer

When creating a work flow with a POST request everything is automatically URL encoded according to the docs.

"Splunk software automatically HTTP-form encodes variables that it passes in POST link actions via URIs. This means you can include values that have spaces between words or punctuation characters."

The endpoint I am hitting expects this data to be in JSON format. Is there anyway to change this so that the request sends application/json instead?

1 Solution

svasani_splunk
Splunk Employee
Splunk Employee

You could do that by setting up the proxy server which listens for application/x-www-form-urlencoded type requests and post's application/json type data.
So you direct your request to proxy server which will do post request in application/json type.

View solution in original post

0 Karma

svasani_splunk
Splunk Employee
Splunk Employee

You could do that by setting up the proxy server which listens for application/x-www-form-urlencoded type requests and post's application/json type data.
So you direct your request to proxy server which will do post request in application/json type.

0 Karma

lakshman239
SplunkTrust
SplunkTrust

does this mean without a proxy server, we cannot post a json data to the application, natively?

0 Karma
Get Updates on the Splunk Community!

Admin Your Splunk Cloud, Your Way

Join us to maximize different techniques to best tune Splunk Cloud. In this Tech Enablement, you will get ...

Cloud Platform | Discontinuing support for TLS version 1.0 and 1.1

Overview Transport Layer Security (TLS) is a security communications protocol that lets two computers, ...

New Customer Testimonials

Enterprises of all sizes and across different industries are accelerating cloud adoption by migrating ...