Getting Data In

Help needed with Search to correlate Windows Event Logs

rishiaggarwal
Explorer

Hi All,

I have a requirement to write a Splunk query that will alert if windows event logs capture three EventCodes (independent events) within 30 secs

PseudoQuery :
"EventCode= X, Y, Z| bucket span=30s _time | fields _time hostname EventCode"

Any leads, please?

0 Karma
1 Solution

HiroshiSatoh
Champion

Try this!

index=(your inddex) (EventCode= 4624 OR EventCode= 4672 EventCode= 4676)
| bucket span=30s _time | stats dc(EventCode) as count by _time,hostname|where count=3

View solution in original post

0 Karma

HiroshiSatoh
Champion

Try this!

index=(your inddex) (EventCode= 4624 OR EventCode= 4672 EventCode= 4676)
| bucket span=30s _time | stats dc(EventCode) as count by _time,hostname|where count=3
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Mastering Threat Intelligence in ES 8.5, Splunk AI Assistant v2, and More from Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

Break the Build: Inside the KubeDoom Lounge at .conf26

    You step up to the machine. The pixelated corridors of a certain 1993 FPS load in front of you, EMP Pulse ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...