Getting Data In
Highlighted

HPUX 11.11 or AIX 4.x compatibility?

Splunk Employee
Splunk Employee

A customer in manufacturing who is already using Splunk to monitor their database systems wants to start monitoring some of their other key systems, but a lot of their equipment is pretty old. In particular there is one key server that is running HPUX 11.11 as well as a few servers on AIX 4.3. The current versions of Splunk that are available for download don't support these OS versions, but I was wondering if maybe some older Splunk versions might be compatible and whether we could use them to rig something up to put a Splunk forwarder on those servers.

Tags (3)
0 Karma
Highlighted

Re: HPUX 11.11 or AIX 4.x compatibility?

SplunkTrust
SplunkTrust

Regarding AIX 4.3, it was end-of-support years before Splunk 1.0 was released. According to http://www.splunk.com/company, Splunk shipped their first software in 2006 --- AIX 4.3.3 was EOS before 2004. There were quite a few changes from AIX 4.3.3 to AIX 5.1 that could break Splunk. But, I doubt anyone has done the analysis to know. That said, AIX is known for having pretty good binary compatibility between versions.

I would say "just try it!", but if it doesn't work the chances of Splunk being able to fix it are very very slim. You'd have to dig pretty deep in the aftermarket hardware suppliers to even find a development machine that could run AIX 4.3.3 today.

0 Karma