Getting Data In

Forwarding not working, troubleshooting tips?

Influencer

Receiving splunk server inputs.conf:

[splunktcp://7900]

Sending splunk server outputs.conf:

[tcpout]
defaultGroup = rcvr_7900
indexAndForward = false
disabled = false

[tcpout:rcvr_7900]
server = 10.1.2.3:7900
maxQueueSize = 1000

Sending splunk server inputs.conf:

[monitor:///var/log/messages]
sourcetype = syslog
_TCP_ROUTING = tcpout:rcvr_7900

The splunkd.logs show them connecting:

08-17-2010 08:33:25.234 INFO  TcpOutputProc - Connected to 10.1.2.3:7900 

However, no data has been indexed on rcvr. Both sender and receiver are running 4.1.4. Any tips to track it down?

Thanks, Jon

Tags (1)
0 Karma
1 Solution

Splunk Employee
Splunk Employee

Remove the _TCP_ROUTING clause from your inputs.conf on the forwarder. It is incorrect, and even if corrected (to rcvr_7900, without the tcpout:), with your other configurations (namely, your specification of defaultGroup), it is unnecessary and complicating.

Could you let us know why you decided to include it? If there is documentation suggesting this is necessary, it should be corrected.

View solution in original post

Path Finder

Is your forwarder indexing? If so, are any events being 'tagged' to an index other than main (the default) which might not exist on the receiving instance?

0 Karma

Influencer

All local inputs, sorry. The only input is the port 7900 listener as defined in the OP.

0 Karma

Path Finder

all inputs are disabled on your forwarder? Something has to be enabled so events can be forwarded on, at least.

0 Karma

Influencer

No, using a forwarder license and all inputs disabled. Searches don't return the test logs I've been sending to it -- neither on it nor the intended receiver.

0 Karma

Builder

Is the indexer set-up to receive SSL by any chance? I'm wondering if you're sending non-SSL to an SSL-enabled indexer. I had that problem at first.

0 Karma

Influencer

No, no ssl enabled.

0 Karma

Splunk Employee
Splunk Employee

Remove the _TCP_ROUTING clause from your inputs.conf on the forwarder. It is incorrect, and even if corrected (to rcvr_7900, without the tcpout:), with your other configurations (namely, your specification of defaultGroup), it is unnecessary and complicating.

Could you let us know why you decided to include it? If there is documentation suggesting this is necessary, it should be corrected.

View solution in original post

Influencer

I don't want to index the data locally, and I thought this was the magic to prevent it. The inputs.conf doc says:

_TCP_ROUTING = ,,
* comma separated list of tcpout group names
* Using this you can selectively forward your data to specific indexer(s).
* Specify the tcpout group forwarder should use when forwarding your data.
The tcpout group names are defined in outputs.conf with [tcpout:]
* Defaults to groups present in 'defaultGroup' in tcpout stanza in outputs.conf.

0 Karma

Communicator

you need the following in the inputs.conf for it to listen on the indexer

[splunktcp://7900] disabled = false queue = indexQueue sourcetype = tcp-7900

0 Karma

Influencer

Thanks for the suggestions. Unfortunately, no help.

0 Karma

Splunk Employee
Splunk Employee

The original poster's indexer configuration is sufficient. The queue setting is not required and in fact should not be used on a 4.x+ indexer, and the sourcetype should be set at the forwarder.

0 Karma