Getting Data In

Forwarder not uninstalling?

reedmohn
Communicator

Anyone know the details of this known issue with 4.3.3?

SPL-52583 "Universal Forwarder does not uninstall properly"

Is this something that could happen everywhere or is it just under special circumstances?
So far I've got one test client with 4.3.3 that won't uninstall.

This is a potential disaster, because we desperately need to upgrade from 4.3.1 and 4.3.2, which both have catastrophic flaws.

0 Karma
1 Solution

ahattrell_splun
Splunk Employee
Splunk Employee

The issue you refer to above is actually expected behaviour and relates to general windows configuration. It does not really relate to Splunk at all.

Whilst you install Splunk (or any other product) as an Admin user you will get the option to make the program available for all users, or just the current user. If you select current user, then only the current used Admin account
can uninstall the program.

So imagine you have admin account A and admin account B. If A installs and selects current user B will not be able to uninstall the product. A, however, can successfully uninstall as normal.

If you install for all users, then any admin account is capable of removing the product.

As noted in the case you've logged on this issue - if the uninstall problems do not relate to multiple accounts, then you may be hitting a different issue. We will need to investigate this further.

View solution in original post

ahattrell_splun
Splunk Employee
Splunk Employee

The issue you refer to above is actually expected behaviour and relates to general windows configuration. It does not really relate to Splunk at all.

Whilst you install Splunk (or any other product) as an Admin user you will get the option to make the program available for all users, or just the current user. If you select current user, then only the current used Admin account
can uninstall the program.

So imagine you have admin account A and admin account B. If A installs and selects current user B will not be able to uninstall the product. A, however, can successfully uninstall as normal.

If you install for all users, then any admin account is capable of removing the product.

As noted in the case you've logged on this issue - if the uninstall problems do not relate to multiple accounts, then you may be hitting a different issue. We will need to investigate this further.

View solution in original post