Getting Data In

Form with a multi-value text box that will OR every input values

harish_ka
Communicator

How to search multiple values in a text box, that should return results for all the input values.
For Ex, i have a textbox named Num in dashboard, now i can search only 1 input value,
How can i search multiple values, so that i can enter like 10,12,33 , which returns all 3 input results.
The textbox should accept the values like (Num=10 OR Num=12 OR Num=33)

Tags (1)

gjones_splunk
Splunk Employee
Splunk Employee

Hi there,

Bit late in answering (but in case anyone has the same question) I had a bit of help from a colleague on this and it works a treat. Use this xml in a dashboard (against index=_internal) to get an idea of how it works.

Text Input Multi-value Filter

<input type="time" token="TimePicker">
  <label>Time Picker</label>
  <default>
    <earliest>-60m@m</earliest>
    <latest>now</latest>
  </default>
</input>
<input type="text" token="Text_Input">
  <label>Sourcetype text filter with "," separator. It also uses the rex command in the search so you don't have to worry about spaces.</label>
  <prefix>"</prefix>
  <suffix>"</suffix>
</input>


<panel>
  <title>Example of events dedup'd by sourcetype</title>
  <table>
    <search>
      <query>index=_internal  

[ makeresults
| eval sourcetype=$Text_Input$
| makemv tokenizer="([^,]+),?" sourcetype
| mvexpand sourcetype
|rex field=sourcetype mode=sed "s/\s+//g" ]
| dedup sourcetype
| table _time host source sourcetype
$TimePicker.earliest$
$TimePicker.latest$

10
none
progressbar



Sourcetypes to filter on.



index=_internal
| stats values(sourcetype)
$TimePicker.earliest$
$TimePicker.latest$

none

0 Karma

sundareshr
Legend
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...