Getting Data In

Find events from two source, when ip1=ip2

dbabanov
Path Finder

Hello!

I have two source. First is IPS, second is ASA.
I want to find unique IP address ("dest_ip") with signature 2245 OR 2700.
My query is:
sourcetype="snort" 2245 OR 2700 | dedup dest_ip | table dest_ip
And now, i want to find events with this unique IP addess in ASA log. In ASA log IP called "srcip".

sourcetype="asa" | append [search sourcetype="snort" 2245 OR 2700 | dedup dest_ip | table dest_ip] | where srcip=destip

I think it is very simple, but I cannot find any answers and solutions to my question. 😞

Thank in advance!

Tags (3)
0 Karma

dbabanov
Path Finder

Thanks for your answer.
First search work perfectly.
But I think, this is not the fastest and optimized search...
Are you agree with me?

0 Karma

somesoni2
Revered Legend

Try this

sourcetype="asa"  [search sourcetype="snort" 2245 OR 2700 | stats count by dest_ip | rename dest_ip as srcip | table srcip | format] 

OR (slower)

 sourcetype="snort" 2245 OR 2700 | stats count by dest_ip | map maxsearches=1000 search="sourcetype=asa src_ip=$dest_ip$"
0 Karma

somesoni2
Revered Legend

I do agree. There best method will be to use lookup table (if no of dest_ips are low, which I believe will not be) OR use of summary indexing. You can schedule a saved search to write into a custom summary index hourly or daily, per your requirement, list of all dest_ip with signature 2245 OR 2700. Once that is setup, in the first query subsearch,instead of searching the main index, you'll just search from summary index data which is already summarize and will be much much faster (personal experience)

http://docs.splunk.com/Documentation/Splunk/6.1/Knowledge/Configuresummaryindexes

0 Karma

dbabanov
Path Finder

Thanks for your answer.
First search work perfectly.
But I think, this is not the fastest and optimized search...
Are you agree with me?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Laser Bananas and Edge Hubs: Exploring Operational Technology (OT) Data Through a ...

  OT is a different environment to traditional IT and can have interesting challenges when interfacing the ...

Event Series: Mastering AI Tokenomics and Splunk Agent Observability

Beyond the Black Box: Correlating AI Performance and Tokenomics with Splunk Agent Observability   As ...

span_metrics: The OpenTelemetry-Idiomatic Way to See Inside Your Services

You open a trace in Splunk Observability Cloud and everything looks fine. One root span, order-pipeline, with ...