Getting Data In

ERROR: failed to load index config: 'maxTotalDataSizeMB' tag required in config for

Flynt
Splunk Employee
Splunk Employee

My Splunk won't start due to this error! What do I do?

ERROR: failed to load index config: 'maxTotalDataSizeMB' tag required in config for (...)

1 Solution

Flynt
Splunk Employee
Splunk Employee

A few things to check here.

  1. Check your indexes.conf for any typos or non-numeric characters for this field.
  2. Check and make sure your indexes.conf does not contain a comment or any other information AFTER the number - see below

OK :

maxTotalDataSizeMB = 50000  

NOT OK :

maxTotalDataSizeMB = 50000   #Some comment here

View solution in original post

Flynt
Splunk Employee
Splunk Employee

A few things to check here.

  1. Check your indexes.conf for any typos or non-numeric characters for this field.
  2. Check and make sure your indexes.conf does not contain a comment or any other information AFTER the number - see below

OK :

maxTotalDataSizeMB = 50000  

NOT OK :

maxTotalDataSizeMB = 50000   #Some comment here

jrodman
Splunk Employee
Splunk Employee

FWIW, we can't cut configuration values generally with the # mark; for example they are needed in paths, and in regular expressions.

We could theoretically cut values that don't require # marks, but it could get rather tedious in documenting all the execeptions. In short I think it would make using and supporting splunk harder.

yannK
Splunk Employee
Splunk Employee
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

The Trust Gap: Why a Data Foundation is Fundamental to an Agentic Enterprise

The Trust Gap: Why a data foundation is fundamental to an  Agentic Enterprise.   Agentic AI is transforming ...

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...