Getting Data In

Duplicated values on count

vinihei_987
New Member

When I do an stats count my field it return the double of the real number

index=raw_fe5_autsust Aplicacao=HUB Endpoint="*/"
| eval Agrupamento=if(Agrupamento!="", Agrupamento, "AGRUPAMENTO_HOLDING/CE")
| eval Timestamp=strftime(_time, "%Y-%m-%d")
| stats count by Agrupamento, Timestamp
| sort -Timestamp


I already tried dedup and when I count only by Timestamp it works fine

Labels (1)
0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

If Agrupamento is a multi-value field, it will be counted for each value in the multivalue field

| makeresults
| eval field=split("AA","")
| stats count by field _time
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @vinihei_987 ,

are yousure that in some events you have only one Agrupamento?

probaby they are more than one in some (or all) events, so you have a total greter than events.

Ciao.

Giuseppe

0 Karma

richgalloway
SplunkTrust
SplunkTrust

It's not clear what the problem is.  Are you seeing repeated results or are the counts twice the expected values?  It may help to share sanitized output.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...