Getting Data In

DNS lookup failed for "$decideOnStartup": Host not found (authoritative)

beginne_Splunk
Explorer

When 'tail -f /opt/streamfwd/var/log/streamfwd.log' is executed

Why do I get the following message?

WARN [140610710128384] (HTTPRequestSender.cpp:1485) stream.SplunkSenderHTTPEventCollector - (#0) DNS lookup failed for "$decideOnStartup": Host not found (authoritative)
WARN [140610710128384] (HTTPRequestSender.cpp:1470) stream.SplunkSenderHTTPEventCollector - (#0) Recovery attempt failed

Labels (1)
Tags (2)
0 Karma

PickleRick
SplunkTrust
SplunkTrust

The error message says clearly "DNS lookup failed" which means that system resolver cannot determine reliably a hostname for the local IP. You can run some packet capture tool to verify what lookup exactly is performed at the start of the UF.

0 Karma

_JP
Contributor

There's several older posts that seem to be related to a default setting not being correct in their case in an etc/system/local/inputs.conf.  I would check through your Splunk configs to see if there's a server name not set correctly, or if an override is in place that is causing it to use a non-existent hardcoded value instead of relying on what the OS thinks the server name is (i.e. look through our .conf files):

Solved: Inputs.conf $decideonstartup - Splunk Community

Why is host=$decideOnStartup for Splunk Stream, bu... - Splunk Community

How to Configure host = $decideOnStartup correctl... - Splunk Community

Solved: $decideOnStartup Remote Perfmon - Splunk Community

0 Karma

wagenstallerm
Loves-to-Learn Lots

same problem here

0 Karma
Get Updates on the Splunk Community!

.conf24 | Registration Open!

Hello, hello! I come bearing good news: Registration for .conf24 is now open!   conf is Splunk’s rad annual ...

ICYMI - Check out the latest releases of Splunk Edge Processor

Splunk is pleased to announce the latest enhancements to Splunk Edge Processor.  HEC Receiver authorization ...

Introducing the 2024 SplunkTrust!

Hello, Splunk Community! We are beyond thrilled to announce our newest group of SplunkTrust members!  The ...