Getting Data In

Connect to my server

rgill90
New Member

Hi All

I'm trying Splunk for the first time - I'm sifting through the documentation and finding it difficult to ascertain how to install forwarder and do a very basic config with an indexer.

Installed it on my win xp desktop as the indexer and installed the forwader on a test Linux machine. The linux forwarder inputs.conf looks like this:

[tcpout]
defaultGroup = hostnameofwindowslaptop_9997

[tcpout:hostnameofwindowslaptop_9997]
server = hostnameofwindowslaptop:9997

[tcpout-server://hostnameofwindowslaptop:9997]

in the windows server logs i constantly get this:

07-27-2012 11:40:39.274 +0100 ERROR TcpOutputFd - Connection to host=forwarderIP:9997 failed
07-27-2012 11:40:39.274 +0100 WARN TcpOutputProc - Applying quarantine to idx=forwarderIP:9997 numberOfFailures=11

...and on the forwarder in the splunkd.log i get exactly the same error messages.

Can anyone give me any pointers to troubleshoot this? I've tried searching for errors in the web gui search bar over the passed 24 hours and it tells me there's no errors. My forwarder doesn't show in the 'datasources' bit on the search screen either. Bit stumped 😞 Thanks in advance!

Tags (2)
0 Karma

sdaniels
Splunk Employee
Splunk Employee

Do you mean outputs.conf on the forwarder? The inputs file on the forwarder will configure what you are monitoring for data, not the connection back to the indexer server. What you have above looks like configurations i'd expects in outputs.conf on the forwarder.

Check on the indexer inputs.conf to make sure you have this setting as well:

[splunktcp://9997]

0 Karma

iunderwood
Path Finder

Do you have any events being indexed?

0 Karma

rgill90
New Member

well it seems i just had to wait and be patient....suddenly started appearing...gawd knows why / how but the only change i did was the one above

0 Karma

rgill90
New Member

thanks for the quick reply sdanniels

ah yes that's the output.conf on the forwarder. I didn't have that setting on the indexer inputs.conf so it now looks like this:

[default] host = winxphostname

[splunktcp://9997]

still can;t see anything in the deployment monitor and now I'm not sure where to look for clues as to what's wrong 😞

0 Karma
Get Updates on the Splunk Community!

Adoption of RUM and APM at Splunk

    Unleash the power of Splunk Observability   Watch Now In this can't miss Tech Talk! The Splunk Growth ...

March Community Office Hours Security Series Uncovered!

Hello Splunk Community! In March, Splunk Community Office Hours spotlighted our fabulous Splunk Threat ...

Stay Connected: Your Guide to April Tech Talks, Office Hours, and Webinars!

Take a look below to explore our upcoming Community Office Hours, Tech Talks, and Webinars in April. This post ...