Getting Data In

COnfiguration in props.conf not working

ChetanArgekar
Explorer

None of my configurations in props.conf is working and entire file is coming as single event

HEADER_FIELD_LINE_NUMBER = 1 is also not working

Data is server patching data

CHG0030338_Linux_Executive_Summary.log

Change_Request_Number$$@@$$Planned_Start_Date$$@@$$Planned_End_Date$$@@$$CR_Type$$@@$$Type$$@@$$Application$$@@$$Total_Servers$$@@$$Servers_Successfully_Patching$$@@$$Servers_Failed_Patching$$@@$$Servers_Skipped_Patching
CHG0030338$$@@$$9/9/2020 5:45:00 PM (GMT)$$@@$$9/9/2020 5:45:00 PM (GMT)$$@@$$Linux$$@@$$Total$$@@$$1$$@@$$1$$@@$$1$$@@$$0$$@@$$0
CHG0030338$$@@$$9/9/2020 5:45:00 PM (GMT)$$@@$$9/9/2020 5:45:00 PM (GMT)$$@@$$Linux$$@@$$Rhel$$@@$$0$$@@$$0$$@@$$0$$@@$$0$$@@$$0
CHG0030338$$@@$$9/9/2020 5:45:00 PM (GMT)$$@@$$9/9/2020 5:45:00 PM (GMT)$$@@$$Linux$$@@$$CentOS$$@@$$0$$@@$$0$$@@$$0$$@@$$0$$@@$$0
CHG0030338$$@@$$9/9/2020 5:45:00 PM (GMT)$$@@$$9/9/2020 5:45:00 PM (GMT)$$@@$$Linux$$@@$$Suse$$@@$$1$$@@$$1$$@@$$1$$@@$$0$$@@$$0

 

inputs.conf

[monitor:///opt/splunkforwarder/patch/*Summary*.log]
disabled = 0
index = patch_dummy
sourcetype = patch_summary
crcSalt = <SOURCE>

 

props.conf

[patch_summary]
SHOULD_LINEMERGE = false
LINE_BREAKER = ([\r\n]+)
SHOULD_LINEMERGE = false
HEADER_FIELD_LINE_NUMBER = 1
TRANSFORMS-sourcetype = patch_sourcetype
TRANSFORMS-route = patch-monitoring-route

transforms.conf

[patch-monitoring-route]
REGEX = .
DEST_KEY =_TCP_ROUTING
FORMAT = acn-dev1-route-group

[patch_sourcetype]
REGEX = .
DEST_KEY = MetaData:Sourcetype
FORMAT = sourcetype::patch

 

Labels (1)
0 Karma
1 Solution

scelikok
SplunkTrust
SplunkTrust

Hi @ChetanArgekar,

Please try below in props.conf

[patch_summary]
DATETIME_CONFIG=CURRENT
INDEXED_EXTRACTIONS=csv
KV_MODE=none
SHOULD_LINEMERGE=false
LINE_BREAKER=([\r\n]+)
HEADER_FIELD_LINE_NUMBER=1
FIELD_DELIMITER=$
If this reply helps you an upvote is appreciated.

View solution in original post

0 Karma

scelikok
SplunkTrust
SplunkTrust

Hi @ChetanArgekar,

Please try below in props.conf

[patch_summary]
DATETIME_CONFIG=CURRENT
INDEXED_EXTRACTIONS=csv
KV_MODE=none
SHOULD_LINEMERGE=false
LINE_BREAKER=([\r\n]+)
HEADER_FIELD_LINE_NUMBER=1
FIELD_DELIMITER=$
If this reply helps you an upvote is appreciated.
0 Karma

ChetanArgekar
Explorer

It worked thanks for help

0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!

Review:





Or Learn More in Our Blog >>