Getting Data In

Alert when Splunk Universal Forwarder stops working/if uninstalled

walterkobayashi
Engager

Hello,

How can I get alerts when Splunk UF is uninstalled on a Windows Machine? Or even if the SplunkForwarder Service is Stopped?
Is there anyway?

0 Karma

ddrillic
Ultra Champion

Start maybe with the generic query -

    | metadata type=hosts index=* 
    | eval host=lower(host) 
    | eval _time=recentTime 
    | sort host, _time 
    | stats latest(_time) as recentTime by host 
    | eval LAST=strftime(recentTime,"%a %m/%d/%Y-%T %Z(%z)"), DAYS_AGO=round((recentTime-now())/86400,0) 
0 Karma

swong_splunk
Splunk Employee
Splunk Employee

You can find a list of forwarders in the monitoring console under Settings, monitoring console (or DMC for older versions), then select Forwarders, Forwarders: deployment. In the Status and Configuration section, open the report in search (magnifying glass icon). Once in the search mode, you can adjust the search query to your specific needs and Save As an alert.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...