Getting Data In

AD user groups

lucasjeff
New Member

I am looking to monitor specific AD user groups and want to create a search that alerts me to when the members of these groups change.

How do I pull that information?

Tags (1)
0 Karma

brooklynotss
Path Finder

Or a little more robust, create a lookup csv file with the list of groups you care about, your "privileged groups" if you will and refer to it in your search like so:

index=wineventlog tag::host="domaincontroller" eventtype=msad-nt6-groupmembership-changes  NOT "[domainname]\\[serviceaccountthatmakeslotsofchanges]" | eval AdminAccount=upper(replace(mvindex(Security_ID,0), "[domainname]\\\\", "")) | eval ChangedAccount=upper(replace(mvindex(Security_ID,1), "[domainname]\\\\", "")) | eval GroupName=replace(mvindex(Security_ID,2), "[domainname]\\\\", "") | fields _time, host, AdminAccount, ChangedAccount, GroupName, name | search [|inputlookup PriviledgedGroups | fields GroupName] | table _time, host, AdminAccount, ChangedAccount, GroupName, name | rename name as "Action" | sort - _time

Explanation:
We've tagged all our Domaincontrollers
We have only one domain and have both ldap and windows infrastructure app installed so i'm piggy backing off one of those eventtypes.
I'm excluding a service account that makes tons of automated changes we don't care about alerting on.
Then grabbing the account that did the action and the account the action was taken upon, cleaning up the text (removing the domain\ portion since we have only one domain).

Then set schedule and alert parameters as needed. Results in an email like shown in the attached filealt text

0 Karma

JeremyHagan
Communicator

You need to collect the Windows Security Event logs from you domain controllers, then you need to create an alert based on a search similar to this:
(EventCode=4732 OR EventCode=4728 OR EventCode=4756) (Group_Name="Domain Admins" OR Group_Name="Enterprise Admins" OR Group_Name="Schema Admins")

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas     Cisco Live 2026 is almost here, and this ...

Data Management Digest – May 2026

Welcome to the May 2026 edition of Data Management Digest!   As your trusted partner in data innovation, the ...