Deployment Architecture

Why am I getting error "Got an invalid master uri ?" trying to apply the shcluster-bundle and am unable to deploy apps?

Communicator

Hello everyone,

I'm running into some trouble deploying apps to my search head cluster. I have a small demo environment set up in my home lab. 2 search heads, 2 indexers, a heavy forwarder, and an instance running all of my deployers. I have indexer clustering working and deploying fine, as is my normal deployment manager. My Search Head cluster master, however, fails to push out apps.

When I run the push command I get an error about an invalid master URI:

bash-4.1$ ./splunk apply shcluster-bundle -target https://192.168.1.114:8089 -auth admin:changeme
 Warning: Depending on the configuration changes being pushed, this command might initiate a rolling restart of the cluster members.  Please refer to the documentation for the details. Do you wish to continue? [y/n]: y
Got an invalid master uri ? fromhttps://192.168.1.114:8089/services/shcluster/status
bash-4.1$ 

This is run on the SH cluster master and the address is that of the cluster captain. I am running this command as the user "splunk" which owns /opt/splunk/*.

When I run the show status command on the captain I also get the cryptic "?":

 Captain:
                  dynamic_captain : 0
                  elected_captain : Mon Nov  9 11:46:20 2015
                               id : FF12C084-634C-4EA4-AB19-5C317941BF37
                 initialized_flag : 0
                            label : SearchHead1
                 maintenance_mode : 0
                         mgmt_uri : ?
            min_peers_joined_flag : 1
             rolling_restart_flag : 0
               service_ready_flag : 0

 Members: 
    SearchHead2
                            label : SearchHead2
                         mgmt_uri : ?
                   mgmt_uri_alias : https://192.168.1.115:8089
                           status : Up
    SearchHead1
                            label : SearchHead1
                         mgmt_uri : ?
                   mgmt_uri_alias : https://192.168.1.114:8089
                           status : Up

Really a stumper. I've done some digging and can't really figure it out. I can manually install the apps by hand, but that defeats the purpose of my efforts up until this point.

Any and all input is appreciated, thanks!

Engager

I just disabled and afterwards enabled the static captain again.

Now the field mgmt_uri is no longer "?" but resolvinf to the IP and Port. Applying the shcluster-bundle has worked now.