Deployment Architecture

Splunk forwarder not connecting to Deployment Server

dantonag
Explorer

Hello,
we are on splunk 6.5.1 (same versione for the forwarder; unfortunately we can't upgrade at the moment).

We installed the forwarder on a Windows machine, and we configured deployment.conf to talk with the deployment server, like this:

[target-broker:deploymentServer]
targetUri = deployment.ourdomain.ext:80

From the forwarder logs, we see that this error is showing up:

02-24-2022 12:19:54.474 +0100 INFO DC:DeploymentClient - channel=tenantService/handshake Will retry sending handshake message to DS; err=not_connected

The communication with deployment.ourdomain.ext seems to be working (telnet works; the DNS is transforming calls to port 80 to port 8089 of the deployment server).

Why is the forwarder giving that error? We restarted it many times, but with no result.
Thanks

 

Labels (2)
Tags (1)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @dantonag,

is there only one Forwarder with problem or is it present in all your Forwarders?

Anyway, I hint to use the correct 8089 managemen port without DNS redirection, maybe there could be a problem.

In addition use the Deployment Server IP address instead the hostname.

In other words, in deploymentclient.conf use (if 10.10.10.10 is the IP od the DS):

[target-broker:deploymentServer]
targetUri = 10.10.10.10:8089

In addition, I suppose that you have server more recent that the ones certified with version 6.5.1,  has the server with problems the same operative system than other that works or not?

Ciao.

Giuseppe

0 Karma

dantonag
Explorer

Hello,
thanks for you answer.

We have many other forwarders, but they can directly contact the deployment server (they are on a separate network), and they work correctly. For this forwarder, we can't directly contact the deployment server, so we are forced to use the DNS and port 80.

I tried changing the DNS name with the IP, but I have the same error:

02-24-2022 12:53:03.197 +0100 INFO DC:DeploymentClient - channel=tenantService/handshake Will retry sending handshake message to DS; err=not_connected

Thanks

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @dantonag,

I think that the problem is the port redirection hat probably doesn't run.

If this is the problem, I don't know how to help you!

Ciao.

Giuseppe

0 Karma
Get Updates on the Splunk Community!

.conf24 | Registration Open!

Hello, hello! I come bearing good news: Registration for .conf24 is now open!   conf is Splunk’s rad annual ...

Using the Splunk Threat Research Team’s Latest Security Content

REGISTER HERE Tech Talk | Security Edition Did you know the Splunk Threat Research Team regularly releases ...

SplunkTrust | 2024 SplunkTrust Application Period is Open!

It's that time again, folks! That's right, the application/nomination period for the 2024 SplunkTrust is ...