Deployment Architecture

Scripted splunkforwarder deployment: FAILED: Error updating configuration.

ssbarnea
Explorer

Deployment fails with the error: FAILED: Error updating configuration.

The command being executed is
"/opt/splunkforwarder/bin/splunk" set deploy-poll "mymachine.example.com:8089" --accept-license --answer-yes --auto-ports --no-prompt

This command is part for the example deploy script provided by splunk.

Tags (1)
0 Karma

jgedeon120
Contributor
/opt/splunkforwarder/bin/splunk start --accept-license --answer-yes --auto-ports --no-prompt
/opt/splunkforwarder/bin/splunk set deploy-poll mymachine.example.com:8089 -auth admin:changeme
/opt/splunkforwarder/bin/splunk enable boot-start
/opt/splunkforwarder/bin/splunk edit user admin -password $PASSWORD -auth admin:changeme
/opt/splunkforwarder/bin/splunk restart

Is what I use in my script

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Self-Healing Pipeline Is Now Generally Available: AI-Powered CIM Compliance

Maintaining data integrity across security and analytics pipelines is an ongoing challenge. Data ...

Meet Splunk Observability Studio: AI-Assisted OpenTelemetry Instrumentation Without ...

Instrumentation is usually the last step or even an afterthought when building out a project. The feature ...

Federated Search for Cisco Security and Analytics Logging (SAL) is now GA on Splunk ...

Federated Search for Cisco  Security Analytics and Logging (SAL) is now generally available as part of the ...