Deployment Architecture

Javascript/CSS files fail to load on search head?

matstap
Communicator

I deployed an app to my search head cluster. In one of the search heads, the custom javascript/css files for a dashboard are failing to load. None of the search heads have a local directory for this app and the default directories are all identical.

Has anyone had/resolved this same issue? What was the cause? I know without looking at my environment you can't say exactly what the cause is. Just looking for ideas on what to check.

0 Karma
1 Solution

493669
Super Champion

firstly restart your particular search head

View solution in original post

493669
Super Champion

firstly restart your particular search head

493669
Super Champion

add console.log("hello") in your js and bump once then check console if there present hello means js is loaded

0 Karma

matstap
Communicator

That worked. Thanks!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...