Deployment Architecture

Indexer : coldToFrozenScript Could not look up HOME variable

brdr
Contributor

The error below just started showing up in the splunkd.log. Not sure why. We have 2 indexers. This error is only showing up on one of the indexers. Any idea why?

This is the error message:

ERROR BucketMover - coldToFrozenScript Could not look up HOME variable. Auth tokens cannot be cached

Tags (1)
0 Karma

brdr
Contributor

The issue that generated the error message was the result of the path name of the index for the warm db directory was different than the index name. The index name is cim_modifications, but the path name is /data/splunkdb/cim_modificationsdb. This also caused our coldToFrozenScript program to exit with value of 1, which was another indication something was wrong.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...