Deployment Architecture

How to resolve Server Abort error - Nginx Reverse Proxy (load balancing)

BP9906
Builder

I thought I'd mention that I came across an error and worked with Splunk Support to determine the cause.

I had recently upgraded from Spunk 6.3.x to Splunk 6.4.x and I've been using Nginx as reverse proxy for a long time so that I can load balance traffic between peers of my SHC (search head cluster).

The error was happening when I tried to save a search in the Saved Searches menu via Settings > Saved Searches (old style).

The issue was apparent in Chrome console that I was getting conflicting X-Frame-Options headers. Previously I put in this config and changed it to match Splunk:

OLD:
add_header X-Frame-Options DENY;

NOW:
add_header X-Frame-Options "SAMEORIGIN";

This resolved my issue, in case someone else comes across it. Apparently Splunk implemented X-Frame-Options in 6.4 so thats why this issue was happening. I suppose I could remove the header altogether from Nginx but I thought I'd share what the cause and change was that helped me.

1 Solution

BP9906
Builder

Nginx reconfigured.

View solution in original post

0 Karma

BP9906
Builder

Nginx reconfigured.

0 Karma
Get Updates on the Splunk Community!

What’s new on Splunk Lantern in August

This month’s Splunk Lantern update gives you the low-down on all of the articles we’ve published over the past ...

Welcome to the Future of Data Search & Exploration

You have more data coming at you than ever before. Over the next five years, the total amount of digital data ...

This Week's Community Digest - Splunk Community Happenings [8.3.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...